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Introduction
This white paper covers the Advanced Host Controller Interface (AHCI) and Redundant Array of Independent Disks (RAID)
drive technologies that are provided on the HP Compaq EliteDesk/EliteOne 800 Business PC products. This white paper
provides a basic overview of AHCI and RAID technology, factory configurations, other supported RAID configurations, and
basic instructions on how to migrate non-RAID to RAID configurations in the field. HP also provides a Smart IV Hard Drive
technical white paper for Smart IV Technology on HP Business Desktop Hard Drives on www.hp.com. The HP Compaq Elite
800 also supports disk caching, which is described in a separate white paper “Configuring HP EliteDesk/EliteOne 800
Systems for Intel Smart Response Technology” available on www.hp.com.
AHCI is a hardware mechanism that allows software to communicate with Serial ATA (SATA) devices. It is enumerated as a
PCI device and it transfers data between system memory and SATA devices.
HP EliteDesk/EliteOne 800-series Business PC products provide support for AHCI in single and multiple drive configurations.
RAID (Redundant Array of Independent Disks) employs two or more drives in combination for fault tolerance and
performance. Initially used with servers, desktop PCs are increasingly using RAID by adding a RAID controller and extra IDE
or SCSI disks.
HP EliteDesk/EliteOne 800-series Business PCs take advantage of Serial Advanced Technology Attachment (SATA)
technology and the integration of RAID support into select Intel chipsets. Both the EliteDesk and EliteOne 800 business PCs
use the Q87 Express chipset.

Basic AHCI and RAID definitions
Table 1. Basic AHCI and RAID definitions
Acronym or term

Description

AHCI

Advanced Host Controller Interface, a specification for hardware and software, is a register interface
for SATA, intended to add higher speed, NCQ and other features.

ATA

Advanced Technology Attachment.

BIOS

Basic Input/Output System, also known as system ROM.

Chipset

Term used to define a collection of integrated components required to make a PC function.

HDD

Hard disk drive

ICH

The Input/Output Controller Hub. This component includes the mass storage controller. ICH is part of
the Intel Q45 Chipset

IDE

Integrated Drive Electronics

INF

Information file (.inf) used by Microsoft® operating systems that support the Plug & Play feature.
When installing a driver, this file provides the operating system needed, information about driver
filenames, driver components, and supported hardware.

Migration

Term used to describe the movement of data from one configuration or usage model to another.

NCQ

Native Command Queuing.

OS

Operating system

Option ROM

Piece or software module inside the System BIOS which provides extended support for a particular
piece of hardware. The RAID Option ROM provides boot support for RAID volumes as well as a user
interface for managing and configuring the system's RAID volumes.

PCH

Platform Controller Hub. This component includes the mass storage controller. PCH is part of the
Intel Q87 chipset

PCI

Peripheral Components Interface.

PCIe

PCI express. A serial version of PCI.
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Table 1. Basic AHCI and RAID definitions
Acronym or term

Description

PnP

Plug and Play

RAID

Redundant Array of Independent Disks.

ROM

Read Only Memory.

SATA

Serial ATA

Strip

Set of data on a single hard drive in a RAID 0 volume.

Stripe

Group of all strips going horizontally across all the hard drive members of a RAID volume.

UEFI

Unified Extensible Firmware Interface. Specification defining firmware (BIOS and/or option ROM) that
initializes hardware subsystems before the OS boot process.

Benefits of AHCI
AHCI provides several benefits:
• Elimination of master/slave handling
• Native Command Queuing (NCQ)
• Hot-plugging

AHCI mode eliminates the master/slave topology for cabling SATA hard drives. Hardware and software that emulate IDE still
have some limitations with the master/slave topology that came from the Parallel ATA (PATA) mass storage
implementation. With AHCI mode, there is no need to worry about cabling considerations, other than the boot drive should
be on the lowest numbered SATA port (dark blue connector). SATA ports are independent of each other and are not tied
together by master/slave relationship.
Native Command Queuing (NCQ) is technology that allows a SATA device to internally optimize the order of command
execution for increased performance. Commands sent to a NCQ-capable SATA device are placed in an internal queue where
they can be dynamically and intelligently re-ordered and tracked.
Hot-plugging is the ability to insert a SATA device into a running system and have the operating system recognize the
device. AHCI is required for eSATA hot-plug functionality. Refer to the “Using eSATA on HP Compaq Business PCs” white
paper for more information about eSATA hot-plugging.

BIOS / Software / Hardware Considerations
BIOS interface
SATA Emulation Mode
SATA emulation mode can be set in F10 Setup by selecting Storage > Storage Options > SATA Emulation. SATA emulation
mode is set to AHCI by default. This is a change from previous HP Compaq dc7xxx Business PCs, which had a default SATA
emulation mode of IDE (legacy).
RAID SATA emulation mode includes AHCI functionality. Customers purchasing a RAID system do not need to make any
changes in F10 Setup.
BIOS Support for _GTF in ACPI Mode
The system BIOS supports the Get Task File (_GTF) ACPI control method while in AHCI mode. However, a Registry key is
required to enable the port(s).
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Software drivers
AHCI driver
In addition to setting the SATA emulation mode of AHCI or RAID in F10 Setup (See the BIOS interface section for more
information), an AHCI driver is required for AHCI support.
The Windows 7 image that ships with the HP EliteDesk/EliteOne 800-series Business PC has the Intel AHCI driver (iastor.sys)
pre-loaded. The system can be freely switched between IDE to AHCI.

Note
In order to reuse a hard drive from a RAID configuration in AHCI mode, it is necessary to remove RAID metadata from the
drive. This can be accomplished using low level system format or Option ROM interface.

For customers who do not use the pre-installed HP image, there are several scenarios for using AHCI:
New operating system installation
A fresh installation of Windows 7 or Windows 8, while in AHCI mode, is the most straightforward way of installing the AHCI
driver.
Windows 7 or Windows 8 have native AHCI support, so either the native AHCI driver will be used or the Intel AHCI driver can
be added.
An existing Windows 7 or Windows 8 image using the native AHCI driver can be updated to use the Intel AHCI driver
(iastora.sys). The driver can be downloaded from hp.com .
Enhancing existing Windows 7 images from IDE mode or native AHCI mode.
Windows 7 has a native AHCI driver. If Windows 7 was installed while in IDE mode, a registry change will allow users to
gracefully switch to AHCI mode using the Microsoft driver. See the Microsoft Knowledge Base Article at
http://support.microsoft.com/kb/922976/en-us . .
Corporate IT may be able to update an existing Window 7 image that was created in IDE mode to use the Intel AHCI driver.
The process requires inserting the Intel AHCI drivers into the image in a pre-installation environment using the appropriate
OS Tools.
Required software to insert the Intel AHCI driver:
• Windows Preinstallation Environment (WinPE) CD
• Windows OPK (OEM Preinstallation Kit) CD
• PKGMGR.EXE (Package Manager)

The OPK CD is not available for general download. It must be obtained through a Microsoft authorized distributor.
PKGMGR.EXE is a tool that installs, uninstalls, configures, and updates features and packages for Windows 7 or Windows 8.
For more information and instructions on OPK or PKGMGR.EXE, go to http://www.hp.com.
The process is as follows:
1.
2.

Boot into WinPE.
Run PKGMGR.EXE from OPK. A sample command line is as follows:
pkgmgr.exe /o:"C:\;C:\Windows" /n:"C:\AddAHCI\HP-AHCI.xml"
…where “C:\AddAHCI\HP-AHCI.xml” contains the following:

<?xml version="1.0" ?>
<unattend xmlns="urn:schemas-microsoft-com:asm.v3" xmlns:wcm="http://

schemas.microsoft.com/WMIConfig/2002/State">
<settings pass="offlineServicing">
<component name="Microsoft-Windows-PnpCustomizationsNonWinPE"
processorArchitecture="x86"
publicKeyToken="31bf3856ad364e35" language="neutral"
versionScope="nonSxS">
<DriverPaths>
<PathAndCredentials wcm:keyValue="1">
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<Path>C:\AddAHCI</Path>
</PathAndCredentials>
</DriverPaths>
</component>
</settings>
</unattend>
3.
4.
5.

Reboot the computer.
Enter F10 Setup and change SATA Emulation mode to AHCI.
Reboot the computer into the OS.

An existing Windows 7 or Windows 8 image using the native AHCI driver can be updated to use the Intel AHCI driver
(iastor.sys). The driver can be downloaded from hp.com .

Note
Be careful when moving an image to computer with a different chipset. The Device ID of the AHCI controller must match
what is in the INF or the AHCI driver will fail and the computer will not boot.

Hardware
The HP EliteDesk/EliteOne 800series Business PCs uses Intel chipsets that support an AHCI-capable Host Bus Adapter (HBA).
This HBA supports ATA and ATAPI devices in both PIO and DMA modes with NCQ as long as the device supports NCQ.
All hard drives shipped with the HP EliteDesk/EliteOne 800-series Business PCs are NCQ capable.

Limitations
NCQ functionality requires both HBA and hard drive to support it. Non-NCQ capable hard drives will not see any performance
benefits even though the HBA is NCQ capable.
Hot-plugging is not possible in an operating system without an AHCI driver that supports hot-plugging, such as DOS,
Windows 9x, Windows NT4.0, and older versions of Linux.
Changing AHCI to IDE Mode through the HP Replicated Setup Utility: Multiple AHCI systems can be reverted back to IDE mode
using the HP Replicated Setup Utility. This utility allows for system BIOS settings to be replicated and distributed throughout
an enterprise. The procedures and information about how to obtain the Replicated Setup Utility are described in the HP
white paper “UEFI BIOS Tools for HP Business Desktops” available at
http://h10032.www1.hp.com/ctg/Manual/c02932801.pdf .

Basic RAID Types
This section provides a brief explanation of the supported RAID configurations for HP EliteDesk/EliteOne 800-series
Business PCs.
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RAID 0 with two hard drives (striped)
HP supports RAID 0, but we do not recommend it for business PC users. Lack of redundancy causes less than half the
reliability of a single hard drive system since the Mean Time Between Failure (MTBF) of RAID 0 is equal to the MTBF of an
individual drive, divided by the number of drives.
Figure 1. Performance – RAID 0 with two HDDs

Table 2. RAID 0 with two hard drives (striped).

A B C D…

First disk

Second disk

Data Segment 1

Data Segment 2

Data Segment 3

Data Segment 4

Data Segment 5

Data Segment 6

Data Segment 7

Data Segment 8

Data Segment 9

Data Segment 10

Data Segment 11

Data Segment 12

Data Segment 13

Data Segment 14

Data Segment 15

Data Segment 16

A

B

C

D

E

F

G

H

…

…

HDD 1

HDD 2

In table 2, each “Data Segment n” represents a group of data, known as a strip. In this case, each row represents a stripe.
RAID 0 represented in the table above shows how information is segmented, made into chunks or strips, and stored across
the stripes of the hard drive members of this RAID volume.
To illustrate the concept of RAID 0 and striping, Figure 1 shows how a sequence of data “ABCD...” is stored in a RAID 0 mode.
In this example, each letter represents a segment or strip. The graphic shows how the various pieces of the information go
to different hard drives. If any segment of RAID 0 fails, all information from all members is lost.
At a higher reliability cost with faster performance, the HP Compaq EliteDesk/EliteOne 800-series Business PC Convertible
Minitower also allows for RAID 0 with three hard drives. RAID 0 with two or three hard drives is a supported configuration.
RAID 0 with three hard drives is shown in Figure 2.
Figure 2. Performance – RAID 0 with three HDDs.

A B C D…
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B

C

D

E

F

G

H

I

J

K

L

…

…

…

HDD 1

HDD 2

HDD 3
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RAID 1 with two hard drives (Mirroring)
Because it is a very cost-effective way to increase system storage reliability and a great value proposition, RAID 1 is the only
RAID configuration that HP pre-configures for HP EliteDesk/EliteOne 800-series Business PCs. RAID 1 provides high
availability with minimal performance impact, as well as greater reliability compared to a single hard drive configuration.
RAID 1 has redundancy and hence is a true RAID. It more than doubles reliability because the MTBF of RAID 1 is equal to the
MTBF of an individual drive multiplied by the number of drives (2). In other words, the probability of one hard drive failure on
a given day is the square root of that same probability. Hypothetically, if the chance for a single hard drive failure is 1:2000,
then the chance that both hard drives failing in RAID 1 is 1:4,000,000.
Mirroring, segmentation, and striping have no real meaning in RAID 1. In the table and graphic, the data is arranged in rows
for representation of different pieces of data.
Table 3. RAID 1 with two hard drives (mirrored).
First disk

Second disk

Data Segment 1

Data Segment 1

Data Segment 2

Data Segment 2

Data Segment 3

Data Segment 3

Data Segment 4

Data Segment 4

Data Segment 5

Data Segment 5

Data Segment 6

Data Segment 6

Data Segment 7

Data Segment 7

Data Segment 8

Data Segment 8

Figure 3. Reliability – RAID 1 with two HDDs

A B C D…

A

A

B

B

C

C

D

D

…

…

HDD 1

HDD 2

In Table 3, each “Data Segment n” represents a group of data, known as a strip. In this case, each row represents a stripe.
This table shows how information is duplicated in both hard drives. The size of the strips is mostly irrelevant and not a
configurable option.
To illustrate the concept of RAID 1 and mirroring, Figure 3 shows how a sequence of data “ABCD...” is stored in a RAID 1
volume. In this example, each letter represents a data segment. The graphic shows how the various pieces are replicated for
both of the hard drives; hence, if any one member of the RAID 1 volume fails, the information is kept in the surviving
members. After a hard drive failure, the user interface sends a notification so the failed hard drive can be replaced. No user
information is lost in this scenario.
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RAID 5 with three hard drives
RAID 5 has been used in servers for many years and is one of the most common types of RAID. RAID 5 uses striping with
parity data in distributed blocks across all member disks. Therefore, the mass storage controller can simultaneously write
new information to two hard drives and parity information to the third hard drive, so if one hard drive fails, the RAID
controller can rebuild all the information after the volume degradation occurred. Hence, RAID 5 with three hard drives has
similar performance to RAID 0 with two hard drives, and the reliability of RAID 1 with a minimum of three hard drives.
Table 4. RAID 5 with three hard drives (parity).
First disk

Second disk

Third disk

Data Segment 1

Data Segment 2

Parity for 1 and 2

Data Segment 3

Parity for 3 and 4

Data Segment 4

Parity for 5 and 6

Data Segment 5

Data Segment 6

Data Segment 7

Data Segment 8

Parity for 7 and 8

Data Segment 9

Parity for 9 and 10

Data Segment 10

Parity for 11 and 12

Data Segment 11

Data Segment 12

Data Segment 13

Data Segment 14

Parity for 13 and 14

Data Segment 15

Parity for 15 and 16

Data Segment 16

Parity for 17 and 18

Data Segment 17

Data Segment 18

Figure 4. RAID 5 with three HDDs.

A B C D E F…

A

B

PA-B

C

PC-D

D

PE-F

E

F

…

…

…

HDD 1

HDD 2

HDD 3

Intel Matrix RAID Technology
This technology provides protection against data loss from a hard drive failure and faster access to digital photo, video, and
music files by supporting NCQ as well as RAID 0, 1, 5, and 10. As shown in Figure 5, Matrix RAID enables two RAID levels to
be combined for data loss protection plus performance.
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Figure 5. Matrix RAID combining reliability and performance with the same two hard drives.

A

B

A

A

C

D

B

B

E

F

C

C

G

H

D

D

…

…

…

…

RAID 1 partition
(mirroring for reliability)

HDD 1
HDD 2
2 HDDs on RAID 0

A

A

B

B

E

F

G

H

HDD 1
HDD 2
2 HDDs on RAID 1

RAID 0 partition
(striped for performance)

HDD 1

HDD 2

Using Intel Matrix RAID Technology, you can configure an HP EliteDesk/EliteOne 800-series Business PC Convertible Minitower with two RAID volumes using three hard drives (Figure 6) - a RAID 0 volume for ultimate performance, and a second
volume as RAID 5 with reliability and performance improvements.
Figure 6. Matrix RAID combining reliability and performance with the same three hard drives
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C
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E
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D
F
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D
G
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E
H
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F
I
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RAID 5 partition
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A
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E
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F
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F
I

RAID 0 partition
HDD 1
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Configurations
Recommended configurations
HP recommends factory configurations of the preinstalled RAID offerings for HP EliteDesk/Elite 800-series Business PCs.
The preinstalled RAID offering is a RAID 1 volume of two identical SATA hard drives.
HP EliteDesk/EliteOne 800-series Business PCs are based on Intel chipsets that provide a combined hardware and software
RAID solution. The Intel mass storage controller allows all drives to operate in IDE or RAID SATA modes. Each mode of the
controller means a different PCI controller, with different device ID, class code, and driver support.

CAUTION
The PCI Device ID of the mass storage controller changes after changing SATA emulation mode in the BIOS. Changing the
BIOS from AHCI mode to RAID mode is the equivalent of connecting the hard drives to a new add-on RAID storage controller.
The installed operating system on the hard drive is unaware of this new mass storage controller. If the operating system
does not have the RAID drivers enumerated and PnP for the RAID controller, the operating system will fail to boot (blue
screens) when Windows 7 or Windows 8 attempts to boot.

Table 5. RAID drives.
Mode

Purpose

Minimum drives required

RAID 0

Striped for Performance.

2

RAID 1

Mirrored for Protection.

2

RAID 5

Parity for Accuracy.

3

RAID 0 + 1

Mirrored and Striped.

4 (Not supported on HP
EliteDesk/EliteOne 800-series business
PCs)

Intel’s Rapid
Technology

4 logical drives on 2 physical disks, to
emulate RAID 0 and 1

2

The following notes are important for RAID configurations:
• RAID 1 is the only RAID configuration that HP EliteDesk/EliteOne 800-series Business PC products offer as factory

configuration option.
• All pre-configured systems:

– Are complete RAID systems
– Have both drives installed
– Have the necessary Option ROM configuration
– Are pre-loaded and pre-installed with all required Intel software
– Include a preinstalled operating system that is mirrored mode out of the box
• We also recommend keeping the default options in the RAID Option ROM and in the Windows RAID application. Options

like “chunk” size for changing the size “stripe” size have more history in their defaults settings.

Other supported configurations
HP EliteDesk/EliteOne 800-series Business PC products support two other RAID configurations:
• Two-drive configuration:

– Two equal size/type SATA hard drive RAID configurations in RAID 0 or RAID 1 or Matrix Mode of RAID 0 and RAID 1.
– Maximum of two SATA optical drives (on HP EliteDesk/EliteOne 800-series Business PC Convertible Minitowers).
• Three-drive configuration (only on some HP EliteDesk/EliteOne 800-series Business PC Convertible Minitowers):

– Three equal size/type SATA hard drive RAID configurations in RAID 0 or RAID 5 or Matrix Mode of RAID and RAID 5.
– Maximum of one SATA optical drives.
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Unsupported configurations
HP EliteDesk/EliteOne 800-series Business Desktop PC products only support configurations offering the best user
experience and highest possible reliability. As a result, HP does not support the following combinations of RAID hard drives:
• Different sizes
• Different speeds (5400 rpm, 7200 rpm, etc)
• Old and new technologies (SATA 1.5 GB and SATA 3.0 GB)
• NCQ hard drives and non-NCQ drives
• Different cache size
• RAID combinations of hard drives with any operating system other than Windows 7 or Windows 8 using Microsoft’s IDE

driver stack based on ATAPI.SYS

Configuring RAID on non-factory preinstalled configurations
The remaining sections of this white paper describe steps to set up supported RAID configurations where customers have
not purchased factory preinstalled RAID configurations.

Enabling RAID through F10 System BIOS
For enabling RAID on Windows 7 and/or legacy platforms, RAID is enabled using the Setup Utility, accessed through F10
during a system boot.
1.
2.
3.
4.
5.
6.
7.

Turn on or restart the computer by clicking Start > Shut Down > Restart the Computer.
Press F10 as soon as the monitor light turns green. If you do not press F10 at the appropriate time, you must restart
the computer, and then press F10 again to access the utility.
Select your language from the list, and then press Enter.
Use the arrow keys to select Storage.
Use the down arrow key to select Storage Options, and then press Enter.
On the Storage Options menu, use the down arrow key to select SATA Emulation.
Press the right arrow key until the RAID option appears, and then press F10 to accept.

8.

To apply and save changes, select File > Save Changes and Exit.

CAUTION
Do NOT turn the computer power off while the ROM is saving the F10 Computer Setup changes, otherwise the CMOS could
become corrupted. Only turn the computer off after exiting the F10 Setup screen.
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Accessing RAID Option ROM
You can only access Computer Setup at system startup. To access the Computer Setup Utilities menu and enable RAID:
1.

Turn on or restart the computer by clicking Start > Shut Down > Restart the Computer.
The following screen (RAID Option ROM) displays briefly during boot up. The RAID configuration utility is English only. To
configure RAID in other languages, use the Windows-based RAID configuration utility.

2.

Press Ctrl + I repeatedly as soon as the monitor light turns green to enter the RAID configuration utility. If you do not
press Ctrl + I at the appropriate time, you must restart the computer, and then press Ctrl + I again to access the utility.
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Configuring RAID Volume using the Option ROM on legacy systems
To configure a RAID volume using the option ROM on legacy (Windows 7) systems, perform the following:

14

1.

Use the up or down arrow key to select Create RAID Volume, and then press Enter to access the Create Volume screen.

2.

Select or enter the desired RAID Level (RAID1 (Mirror) in our example). Use the information on the bottom half of the
screen if necessary.
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3.

Use the arrow keys to scroll to Create Volume, and press Enter. The following message appears. WARNING: All data on
the selected disk will be deleted.

4.

Type Y to continue.

Configuring RAID Volume using the Option ROM on Windows 8/64-bit systems
Windows 8/64-bit systems must be imaged in UEFI mode. To configure a RAID volume in UEFE mode on these systems
using the option ROM, perform the following:
1.
2.
3.
4.
5.
6.

Turn on the computer.
Press F10 as soon as the monitor light turns green. If you do not press F10 at the appropriate time, you must restart
the computer, and then press F10 again to access the utility.
Select your language from the list, and then press Enter.
Use the arrow keys to select Advanced.
Use the down arrow key to select Option ROM Launch Policy, and then press Enter.
In the Option ROM Launch Policy window, use the up/down arrow keys to select Storage Option ROMs and the left/right
arrow keys to select UEFI only. Press F10 to accept (save).
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7.

At the Advanced menu, select Intel (R) Rapid Storage Technology.

8.

At the Intel (R) Rapid Storage Technology menu, select Create RAID volume and press F10.

9.

At the Intel (R) Rapid Storage Technology menu, verify Volume 1 as the RAID volume created and press F10.

Notes for operating system installation
• After creating a RAID disk volume in the option ROM, you can install the operating system.
• HP provides a driver download for supported operating systems at www.hp.com.
• Customer-created images MUST account for the RAID controller.
• Failure to install and enumerate the RAID driver after enabling the RAID controller (with or without creating a volume) will

result in a Windows boot failure (blue screen) for inaccessible boot device.

CAUTION
The PCI Device ID of the mass storage controller changes after changing SATA emulation mode in the BIOS. Changing the
BIOS from AHCI mode to RAID mode is the equivalent of connecting the hard drives to a new add-on RAID storage controller.
The installed operating system on the hard drive is unaware of this new mass storage controller. If the operating system
does not have the RAID drivers enumerated and PnP for the RAID controller, the operating system will fail to boot (blue
screens) when Windows 7 or Windows 8 attempts to boot.
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Intel Rapid Storage Technology software installation
This section of the paper focuses on how to configure RAID using Intel Rapid Storage Technology software. The
configuration steps are for application usage and supported RAID migrations.
1.

Run SetupRST.exe. The initial setup screen appears as shown below.

2.
3.
4.
5.
6.
7.
8.
9.

Click Next.
Read the driver agreement. If you agree, click Next.
Read the License Agreement. If you agree, click Yes.
Review the Readme for Intel Rapid Storage Technology, and then click Next.
Click Next, after the setup operations complete.
Click Next to finish the installation.
Select Restart Now or Restart Later, and then click Finish to close the setup.
Restart the computer.
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Using Intel Rapid Storage console interface to configure RAID
To use the RST console to configure RAID, perform the following steps.
1.

To open the Intel Rapid Storage Console applications, click Control Panel > Intel Rapid Storage Technology The Intel
Rapid Storage Console starts in Status mode by default.

Note
The report the applications generate is very comprehensive. You can view the report at View/System Report. The
report contains information about the driver, operating system, language, and hard drive.
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2.

Select Status to view the current status of the storage system.

3.

For a more detailed view of the RAID controller, click Manage. The Manage Volume window of the Intel Rapid Storage
Console also includes the Advanced menu. Use this menu to access the advanced features of the RAID solution (as
shown below).
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RAID migrations using Intel Rapid Storage Console
Migration to RAID 1 from two non-RAID hard drives

Note
HP EliteDesk/EliteOne 800-series Business PC products only support RAID based on two identical SATA hard drives in either
RAID 0 or RAID 1 or Matrix RAID Mode of RAID 0 and RAID 1.
At least 6 MB of free space at the end of the drive is required to migrate from a non-RAID to RAID configuration or an error
will occur.

1.

Open the Intel Rapid Storage Console and select Create in the top pane.

2.

In the Create Volume window, select the Volume Type in the right pane. Select Real-time data protection (RAID 1) and
click Next.
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3.

In the Configure Volume window, name the volume, select the master and recovery disks, and specify the update
mode. Then click Next.

4.

In the Confirm Volume Creation window, check your proposed configuration, then click Create Volume to continue.
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5.

At the final Confirm Volume Creation window, click Create Volume to confirm that you understand the Volume
Creation process and you want to continue the action.

6.

Click OK after the action completes.

Migration to RAID 0 from two non-RAID hard drives

Note
HP EliteDesk/EliteOne 800-series Business PC products only support RAID based on two identical SATA hard drives in either
RAID 0 or RAID 1 or Matrix RAID Mode of RAID 0 and RAID 1.

To migrate two non-RAID hard drives to a RAID 0 configuration using Intel Rapid Storage Console perform the following
steps:
1.

Open the Intel Rapid Storage Console and select Create and select the volume type Optimized disk performance
(RAID 0).
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2.
3.
4.
5.
6.

Click Next to configure the volume.
In the Configure window, name the volume, select the two disks and specify if you want to keep data from one of the
selected disks.
Click Next to begin the confirmation process and start the Create Volume action.
Click Create Volume to confirm you understand the Volume Creation warning and you want to continue the action.
Click OK after the action completes.

Migration to RAID 0 from three non-RAID hard drives

Note
Back up all data before proceeding.

Note
HP EliteDesk/EliteOne 800-series Business PC products only support RAID based on three identical SATA hard drives in
either RAID 0 or RAID 5 or Matrix RAID Mode of RAID 0 and RAID 5.

1.
2.
3.
4.

Open the Intel Rapid Storage Console and select Create in the top pane and select the Volume Type in the right pane.
Select Optimized disk performance (RAID 0).
Click Next to configure the volume.
In the Configure window, name the volume, select the three disks and specify if you want to keep data from one of the
selected disks.
Click Next to begin the confirmation process and start the Create Volume action.

Note
HP currently supports only the default Strip Size (in this case 128KB). There is a performance relation between the type
of data and the strip sizes.

5.
6.

Click Create Volume to confirm you understand the Volume Creation warning and you want to continue the action.
Click OK after the action completes.

Migration to RAID 5 from three non-RAID hard drives

Note
Back up all data before proceeding.

Note
HP EliteDesk/EliteOne 800-series Business PC products only support RAID based on three identical SATA hard drives in
either RAID 0 or RAID 5 or Matrix RAID Mode of RAID 0 and RAID 5.

1.
2.
3.
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Open the Intel Rapid Storage Console and select Create in the top pane and select the Volume Type in the right pane.
Select Efficient data hosting and protection (RAID 5).
Click Next to configure the volume.
In the Configure window, name the volume, select the three disks and specify if you want to keep data from one of the
selected disks.
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4.

Click Next to begin the confirmation process, review the selected configuration and click Create Volume to start the
Create Volume action.

Note
HP currently supports only the default Strip Size (in this case 128KB). There is a performance relation between the type
of data and the strip sizes.

5.
6.

Click Create Volume to confirm you understand the Volume Creation warning and you want to continue the action.
Click OK after the action completes.

Note
If users consume all available storage for this RAID volume, there will be no space to create another RAID volume for this
hard drive, thereby not allowing for Matrix RAID Mode. Note the size if you want to create a second RAID volume in this set of
hard drives.

7.

Reboot the system after the migration finishes.

Migration to Matrix RAID 5 and RAID 0 from three non-RAID hard drives

Note
Back up all data before proceeding.

Note
HP EliteDesk/EliteOne 800-series Business PC products only support RAID based on three identical SATA hard drives in
either RAID 0 or RAID 5 or Matrix RAID Mode of RAID 0 and RAID 5.

1.
2.
3.
4.

Open the Intel Rapid Storage Console and select View > Advanced Mode.
Click Actions/Create RAID Volume from Existing Hard Drive to open a verification window.
Click Next.
Type the RAID Volume Name, select the RAID Level (for three hard drive RAID 0 or RAID 5 only), and select the Strip
Size.

Note
HP currently supports only the default Strip Size (in this case 128KB).

5.
6.
7.
8.

Click Next to see the selection of hard drives that will be part of this RAID volume.
Select the source hard drive (Port 0), and then click on the arrow to move them to the Selected box.
Click Next.
Select all hard drive members of the RAID volume, and then click the right arrow to place the (port 2 and port 3) hard
drives in the selected box.

Note
If users consume all available storage for this RAID volume, there will be no space to create another RAID volume for
this hard drive, thereby not allowing for Matrix RAID Mode. Note the size if you want to create a second RAID volume in
this set of hard drives.
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9.

To create two volumes based on your space, reliability and performance needs, select the size of the first RAID volume
by sliding the bar or entering the desired volume size. For example, divide in half the available hard drive storage in two
RAID volumes by setting the Percentage of Available Space to 50%, so that 50% of drive capacity is used for RAID 0.
10. Click Next.
11. Click Finish to start the migration process, which can take a few hours.
12. Reboot the system after the migration finishes.

Note
Back up all data before proceeding.

13. After the first RAID volume has been created, create the second RAID volume by opening the Intel Rapid Storage
Console, clicking View > Advanced Mode, and then clicking Actions/Create RAID Volume from Existing Hard Drive.
14. Click Next.
15. Use the same values you entered in the previous RAID volume confirmation and type the RAID Volume Name, select
the RAID Level (for three hard drive RAID 0 or RAID 5 only), and select the Strip Size.

Note
HP currently supports only the default Strip Size (in this case 128KB).

16. Click Next to see the selection of hard drives that will be part of this RAID volume.
17. Since this is the second volume for this set of hard drives, select the existing name in the Available box (Array 0000),
and then click the right arrow to move this array into the Selected box.
18. Click Next. The Specify Volume Size screen is grayed out because the second volume of this Matrix RAID Mode takes the
remaining space. After the selection of all hard drive members of this RAID volume, follow the volume size selection
screen.

Note
The first array volume creation is the place for adjusting the size; the second volume will take any remaining space.

19. While creating the second RAID volume, click Next to open the completion window.
20. Select Finish to start the migration process, which can take a few hours. You can see the state of the Matrix RAID Mode
created by opening the Intel Rapid Storage Console and clicking View > Advanced Mode.
Migration to Matrix RAID 1 and RAID 0 from two non-RAID hard drives
The migration process for two hard drives to RAID Matrix Mode (0 + 1) is very similar to the process described in the section
about migration of three hard drives to matrix mode RAID (0 + 5). The difference in the process is selecting two hard drives
as part of the volume created and selecting RAID 5 instead of RAID 1.
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Configuring Intel Rapid Storage Console for
Email notifications
To configure Intel Rapid Storage Console to send notifications of specified events to a designated email address, use the
following steps:
1.

Open the Intel Rapid Storage Console and select Preferences.

2.
3.

Select the type of event to initiate a notification (all three may be selected).
Enter the email information.
A. SMTP Host (required)
B. Port
C. Sender email address (required)
D. Recipient email address (at least one required)
When done click Apply Changes.

4.

Note
The RST driver does not provide SMTP authentication. If you are using MS Exchange (which is not configured this way by
default), an anonymous relay connector is required.
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Installation
HP desktops come with RAID software preinstalled. However, if reinstallation is necessary, use setup in combination with
the supported flags as listed and described in the sample screen shot (version 12.5) below

Note
Flags and their parameters are not case-sensitive. Flags may be supplied in any order, with the exception of -S and -G,
which must be supplied last. When using the -A flag, a target path may be specified using the -P flag, and the -G and -S flags
are ignored. When using the -O and -G flags, there should be no space between the flag and the argument.
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Table 6. Language support.
Abbreviation

Language

ara

Arabic (Saudi Arabia)

(0401)

chs

Chinese (Simplified)

(0804)

cht

Chinese (Traditional)

(0404)

csy

Czech

(0405)

dan

Danish

(0406)

nld

Dutch

(0413)

enu

English (United States)

(0409)

fin

Finnish

(040B)

fra

French (International)

(040C)

deu

German

(0407)

ell

Greek

(0408)

heb

Hebrew

(040D)

hun

Hungarian

(040E)

ita

Italian

(0410)

jpn

Japanese

(0411)

kor

Korean

(0412)

nor

Norwegian

(0414)

plk

Polish

(0415)

ptb

Portuguese (Brazil)

(0416)

ptg

Portuguese (Standard)

(0816)

rus

Russian

(0419)

esp

Spanish

(0C0A)

sve

Swedish

(041D)

tha

Thai

(041E)

trk

Turkish

(041F)
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Degradation
In the unlikely event that one of your hard drives malfunctions, you will be notified with the following message:

If this occurs, perform the following steps:
1.

Run the Intel Rapid Storage Console application on the system experiencing a degradation to identify the hard drive
that failed and to which port it is connected.

2.

After identifying the hard drive, close all applications, shut down the operating system, power down the unit, unplug
the power cord, and replace the defective hard drive.
After replacing the hard drive, automatic rebuild of the redundancy begins immediately after the system is powered up
and operating system starts. The following message appears:

3.

End of procedure.

Sign up for updates
hp.com/go/getupdated

Share with colleagues

Rate this document

© Copyright 2012, 2013 Hewlett-Packard Development Company, L.P. The information contained herein is subject to change without notice. The only
warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should
be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.
Trademark acknowledgments, if needed.
652391-003, September 2013

